Загрузка страницы

VXLAN Spine leaf Simple BGP ECMP |Part 2/3 |configuration :Arista

𝗙𝗼𝗿 𝗖𝗼𝗺𝗽𝗹𝗲𝘁𝗲 𝗣𝘆𝘁𝗵𝗼𝗻 𝗙𝗼𝗿 𝗡𝗲𝘁𝘄𝗼𝗿𝗸 𝗘𝗻𝗴𝗶𝗻𝗲𝗲𝗿𝘀 𝗖𝗼𝘂𝗿𝘀𝗲:
𝗘𝗻𝗿𝗼𝗹𝗹 𝗳𝗼𝗿 𝗯𝗲𝗹𝗼𝘄 𝗨𝗱𝗲𝗺𝘆 𝗖𝗹𝗮𝘀𝘀: 𝟐𝟎𝟐𝟐 𝐕𝐞𝐫𝐬𝐢𝐨𝐧
𝑫𝒊𝒔𝒄𝒐𝒖𝒏𝒕𝒆𝒅 𝑹𝒆𝒇𝒆𝒓𝒓𝒂𝒍 𝑳𝒊𝒏𝒌:
https://www.udemy.com/course/python-for-network-engineers/?referralCode=35A75AAE1ACA94A15829 This video series demonstrate how to configure VXLAN in Arista with BGP and ECMP as the underlay.
Please Subscribe to My channel below for updated videos
https://www.youtube.com/channel/UCcA2nhdC0wzqyv9x1lk5NnA?sub_confirmation=1
Part 1 : https://youtu.be/7mhqa4cm-5w
Part 2 :https://youtu.be/tiAGOTdaikk
Part 3 :https://youtu.be/96bjU4iuveM
----------------------------------------------------------------------
Part 1 shows BGP underlay network and testing of highavalability in case of single spine failure or any link failure.
Part 2 shows how to configure VXLAN in multiple Leaf switches , configure VNI, assign ports to the VLAN,configure peer VTEPS for host replicationand extend Layer 2 over layer 3 in multiple leaf switches

Part 3 shows how to configure VXLAN gateway and routing between underlay and overlay. Shows direct VXLAN routing config using "ip address virtual" command. Creates one underlay VLAN and validates the communication

Below are the configurations used

Spine1
SPINE01 sh run
hostname SPINE01
interface Ethernet1
no switchport
ip address 10.10.1.1/24
interface Ethernet2
no switchport
ip address 10.10.2.1/24
interface Ethernet3
no switchport
ip address 10.10.3.1/24
ip routing
router bgp 100
maximum-paths 2 ecmp 2
neighbor 10.10.1.2 remote-as 201
neighbor 10.10.1.2 maximum-routes 12000
neighbor 10.10.2.2 remote-as 202
neighbor 10.10.2.2 maximum-routes 12000
neighbor 10.10.3.2 remote-as 203
neighbor 10.10.3.2 maximum-routes 12000
redistribute connected
SPINE01#

Spine2
SPINE02 sh run
hostname SPINE02
interface Ethernet1
no switchport
ip address 20.20.1.1/24
interface Ethernet2
no switchport
ip address 20.20.2.1/24
interface Ethernet3
no switchport
ip address 20.20.3.1/24
ip routing
router bgp 100
maximum-paths 2 ecmp 2
neighbor 20.20.1.2 remote-as 201
neighbor 20.20.1.2 maximum-routes 12000
neighbor 20.20.2.2 remote-as 202
neighbor 20.20.2.2 maximum-routes 12000
neighbor 20.20.3.2 remote-as 203
neighbor 20.20.3.2 maximum-routes 12000
redistribute connected
SPINE02#
Leaf01
LEAF01 sh running-config
hostname LEAF01
vlan 31,41
interface Ethernet1
no switchport
ip address 10.10.1.2/24
interface Ethernet2
no switchport
ip address 20.20.1.2/24
interface Ethernet3
switchport access vlan 31
interface Ethernet4
switchport access vlan 41
interface Loopback1
ip address 101.1.1.1/24
interface Vlan31
ip address virtual 31.1.1.254/24
interface Vlan41
ip address virtual 41.1.1.254/24
interface Vxlan1
vxlan source-interface Loopback1
vxlan udp-port 4789
vxlan vlan 31 vni 3311
vxlan vlan 41 vni 4411
vxlan flood vtep 102.1.1.1 103.1.1.1
ip routing
router bgp 201
maximum-paths 2 ecmp 2
neighbor 10.10.1.1 remote-as 100
neighbor 10.10.1.1 maximum-routes 12000
neighbor 20.20.1.1 remote-as 100
neighbor 20.20.1.1 maximum-routes 12000
redistribute connected
LEAF01#
Leaf2
LEAF02 sh running-config
hostname LEAF02
vlan 32,41
interface Ethernet1
no switchport
ip address 10.10.2.2/24
interface Ethernet2
no switchport
ip address 20.20.2.2/24
interface Ethernet3
switchport access vlan 32
interface Ethernet4
switchport access vlan 41
interface Loopback1
ip address 102.1.1.1/24
interface Vlan32
ip address virtual 31.1.1.254/24
interface Vlan41
ip address virtual 41.1.1.254/24
interface Vxlan1
vxlan source-interface Loopback1
vxlan udp-port 4789
vxlan vlan 32 vni 3311
vxlan vlan 41 vni 4411
vxlan flood vtep 101.1.1.1 103.1.1.1
ip routing
router bgp 202
maximum-paths 2 ecmp 2
neighbor 10.10.2.1 remote-as 100
neighbor 10.10.2.1 maximum-routes 12000
neighbor 20.20.2.1 remote-as 100
neighbor 20.20.2.1 maximum-routes 12000
redistribute connected
LEAF02#

Leaf3
LEAF03 sh running-config
hostname LEAF03
vlan 51
interface Ethernet1
no switchport
ip address 10.10.3.2/24
interface Ethernet2
no switchport
ip address 20.20.3.2/24
interface Ethernet3
switchport access vlan 51
interface Ethernet4
switchport access vlan 51
interface Loopback1
ip address 103.1.1.1/24
interface Vlan51
ip address 51.1.1.254/24
interface Vxlan1
vxlan source-interface Loopback1
vxlan udp-port 4789
vxlan vlan 31 vni 3311
vxlan vlan 41 vni 4411
vxlan flood vtep 101.1.1.1 102.1.1.1
ip routing
router bgp 203
maximum-paths 2 ecmp 2
neighbor 10.10.3.1 remote-as 100
neighbor 10.10.3.1 maximum-routes 12000
neighbor 20.20.3.1 remote-as 100
neighbor 20.20.3.1 maximum-routes 12000
redistribute connected
#VXLANArista
#BGPECMPArista
#SpineLeafArista

Видео VXLAN Spine leaf Simple BGP ECMP |Part 2/3 |configuration :Arista канала NetworkEvolution
Показать
Комментарии отсутствуют
Введите заголовок:

Введите адрес ссылки:

Введите адрес видео с YouTube:

Зарегистрируйтесь или войдите с
Информация о видео
26 января 2019 г. 14:07:55
00:11:26
Другие видео канала
AWS IPSec Site to Site VPN tunnel to Cisco CSR1000v: IKEv2 Configuration example | VPC to onpremisesAWS IPSec Site to Site VPN tunnel to Cisco CSR1000v: IKEv2 Configuration example | VPC to onpremisesInstall Cisco CSR1000v Trial Version EC2 in AWS:Enable SSH access to Ansible for Automation UsecasesInstall Cisco CSR1000v Trial Version EC2 in AWS:Enable SSH access to Ansible for Automation UsecasesNETCONF Network Automation Tutorial: Configure Cisco IOS Interface using YANG & ncclient LibraryNETCONF Network Automation Tutorial: Configure Cisco IOS Interface using YANG & ncclient LibraryMastering Network Automation: Simplifying Cisco NXOS API using JSON formatted commands | ParserMastering Network Automation: Simplifying Cisco NXOS API using JSON formatted commands | ParserNetwork Automation RESTCONF-YANG: Cisco Configuration using API POST Method | Python examplesNetwork Automation RESTCONF-YANG: Cisco Configuration using API POST Method | Python examplesRESTCONF-YANG: Automate Cisco Configuration using API PUT Method | Python and Postman examplesRESTCONF-YANG: Automate Cisco Configuration using API PUT Method | Python and Postman examplesNornir Network Automation Framework:Run multiple tasks from Same script for Cisco IOS configurationNornir Network Automation Framework:Run multiple tasks from Same script for Cisco IOS configurationRaspberry Pi  Remote Server Monitoring over Wifi: Part2 Control LED based on Server TCP Port StatusRaspberry Pi Remote Server Monitoring over Wifi: Part2 Control LED based on Server TCP Port StatusPython :Execute linux terminal commands from Python Script using Subprocess Module | Print stdoutPython :Execute linux terminal commands from Python Script using Subprocess Module | Print stdoutNornir python Tutorial: How to configure cisco devices using napalm_configure nornir_napalm.pluginsNornir python Tutorial: How to configure cisco devices using napalm_configure nornir_napalm.pluginsNetwork Automation: Cisco command parsing using Netmiko Genie Parser | IOS SSH show commandNetwork Automation: Cisco command parsing using Netmiko Genie Parser | IOS SSH show commandPython :Network Automation: Netmiko SSH Keybased Authentication Cisco Example | ssh key vs passwordPython :Network Automation: Netmiko SSH Keybased Authentication Cisco Example | ssh key vs passwordPython :Network Automation Tutorial:Netmiko Introduction|How to initiate SSH to cisco using NetmikoPython :Network Automation Tutorial:Netmiko Introduction|How to initiate SSH to cisco using NetmikoPython: Copy files to Cisco IOS bootflash using SCP function | Netmiko script |copy to local machinePython: Copy files to Cisco IOS bootflash using SCP function | Netmiko script |copy to local machineRaspberry Pi PicoW Retry/Reconnect to SSID: Remote Server Monitoring over Wifi Micropython  Part3Raspberry Pi PicoW Retry/Reconnect to SSID: Remote Server Monitoring over Wifi Micropython Part3Raspberry Pi  Remote Server Monitoring over Wifi: Part2 Control LED based on Server TCP Port StatusRaspberry Pi Remote Server Monitoring over Wifi: Part2 Control LED based on Server TCP Port StatusRaspberry Pi  Remote Server Monitoring over Wifi: Micropython code to monitor tcp port using usocketRaspberry Pi Remote Server Monitoring over Wifi: Micropython code to monitor tcp port using usocketPython Network Automation: Enable Logging for Cisco CLI Command Parser and store output in Log FilePython Network Automation: Enable Logging for Cisco CLI Command Parser and store output in Log FileAnsible: Use PyATS Genie Parser or ntc_templates for Cisco show commands|ansible.utils.cli_parseAnsible: Use PyATS Genie Parser or ntc_templates for Cisco show commands|ansible.utils.cli_parsePython for Network Engineers : Argparse Commandline arguments to configure Network Devices over SSHPython for Network Engineers : Argparse Commandline arguments to configure Network Devices over SSHAnsible AWX/Tower Create custom execution environment Container using Podman|install python packagesAnsible AWX/Tower Create custom execution environment Container using Podman|install python packages
Яндекс.Метрика